Comando aptitude de Linux

comando de aptitud

aptitud está basado en texto Interfaz para el sistema de gestión de paquetes APT. Permite al usuario ver la lista de paquetes y realizar tareas de administración de paquetes como instalar, mejorando , y quitando paquetes. Las acciones se pueden realizar desde una interfaz visual o desde el línea de comando .

Sintaxis

|_+_| |_+_| |_+_| |_+_| |_+_| |_+_| |_+_| |_+_| |_+_|

Comportamiento

El primer argumento que no comienza con un guion (' - ') se considera una acción que debe realizar el programa. Si no se especifica una acción en la línea de comandos, aptitud se inicia en modo visual.



icono de batería desaparecido windows 10
Instalar en pc Instale uno o más paquetes. Los paquetes deben aparecer después del ' Instalar en pc 'comando; si el nombre de un paquete contiene un carácter de tilde (' ~ ') o un signo de interrogación (' ? '), se tratará como un patrón de búsqueda y se instalarán todos los paquetes que coincidan con el patrón.

Para seleccionar un particular versión del paquete, anexar = al nombre del paquete: por ejemplo, aptitude install apt = 0.3.1 . Del mismo modo, para seleccionar un paquete de un archivo , adjuntar / al nombre del paquete: por ejemplo, aptitude install apt / experimental . No puede especificar un archivo y una versión para un paquete.

No es necesario instalar todos los paquetes que aparecen en la línea de comandos; puede decirle a aptitude que haga algo diferente con un paquete agregando un 'especificador de anulación' al nombre del paquete. Por ejemplo, aptitud quitar wesnoth + instalará 'wesnoth', no lo eliminará. Están disponibles los siguientes especificadores de anulación:

paquete + Instalar en pc paquete .
paquete + M Instalar en pc paquete e inmediatamente marcar como instalado automáticamente (tenga en cuenta que si nada depende de paquete , esto hace que se elimine inmediatamente).
paquete - Eliminar paquete .
paquete _ Purga paquete : elimínelo y todos sus archivos de datos y configuración asociados.
paquete = Lugar paquete en espera: cancele cualquier instalación, actualización o eliminación activa y evite que este paquete se actualice automáticamente en el futuro.
paquete : Mantenerse paquete en su versión actual: cancele cualquier instalación, eliminación o actualización. A diferencia de 'mantener' (arriba), esto no evita las actualizaciones automáticas en el futuro.
paquete &METRO Marcos paquete como si hubiera sido instalado automáticamente.
paquete &metro Marcos paquete como si hubiera sido instalado manualmente.
Como caso especial, ' Instalar en pc 'sin argumentos actuará sobre cualquier acción almacenada / pendiente.

Una vez que ingrese 'Y' en el mensaje de confirmación final, Instalar en pc El comando modifica la información almacenada de aptitude sobre qué acciones realizar. Por lo tanto, si emite (por ejemplo) el comando aptitude install foo bar y luego cancele la instalación una vez que aptitude haya comenzado a descargar e instalar paquetes, debe ejecutar aptitud eliminar foo bar para cancelar ese pedido.
retirar , purga ,
mantener , despojar ,
mantenerse , reinstalar
Estos comandos son los mismos que Instalar en pc , pero aplique la acción nombrada a todos los paquetes dados en la línea de comando para los que no se anula.

La diferencia entre mantener y mantenerse es eso mantener hace que un paquete sea ignorado por el futuro actualización segura o comandos de actualización completa, mientras mantenerse simplemente cancela cualquier acción programada en el paquete. despojar permite que un paquete se actualice en el futuro actualización segura o actualización completa comandos, sin alterar de otro modo su estado.

Por ejemplo, aptitud eliminar '~ ndeity' elimina todos los paquetes cuyo nombre contenga 'deidad'.
marcauto ,
unmarkauto
Marque los paquetes como instalados automáticamente o instalados manualmente, respectivamente. Los paquetes se especifican de la misma forma que para el Instalar en pc mando. Por ejemplo, aptitude markauto '~ slibs' marcará todos los paquetes en la sección 'libs' como instalados automáticamente.
depende de la construcción ,
build-dep
Satisfacer las dependencias de construcción de un paquete. Cada nombre de paquete puede ser un paquete fuente, en cuyo caso se instalan las dependencias de compilación de ese paquete fuente; de lo contrario, los paquetes binarios se encuentran de la misma manera que para el Instalar en pc comando, y se satisfacen las dependencias de compilación de los paquetes fuente que compilan esos paquetes binarios.

Si el parámetro de la línea de comandos --arch-only está presente, solo dependencias de compilación dependientes de la arquitectura (es decir, no Construir depende de Indep o Construir-Conflictos-Indep ) será obedecido.
prohibir la versión Prohibir que un paquete se actualice a una versión en particular. Esto evita que aptitude se actualice automáticamente a esta versión, pero permite actualizaciones automáticas a versiones futuras. Por defecto, aptitude selecciona la versión del paquete; puede anular esta selección agregando = al nombre del paquete: por ejemplo, aptitude forbid-version vim = 1.2.3.broken-4 .

Este comando es útil para evitar versiones dañadas de paquetes sin tener que establecer y borrar retenciones manuales. Si decides que quieres la versión prohibida después de todo, instalación de aptitud elimina la prohibición.
actualizar Actualiza la lista de paquetes disponibles de las fuentes de apt (esto es equivalente a apt-get update ).
actualización segura Actualiza los paquetes instalados a su versión más reciente. Los paquetes instalados no se eliminarán a menos que no se utilicen. Los paquetes que no están instalados actualmente pueden instalarse para resolver dependencias a menos que el --no-nuevas-instalaciones Se proporciona la opción de línea de comandos.

Si no aparece en la línea de comandos, aptitude intenta actualizar todos los paquetes que se pueden actualizar. De lo contrario, aptitude intenta actualizar solo los paquetes que se le indica que actualice. La s puede extenderse con sufijos de la misma manera que los argumentos para instalación de aptitud , por lo que también puede dar instrucciones adicionales a aptitude aquí; por ejemplo, aptitude safe-upgrade bash dash- intenta actualizar el paquete 'bash' y eliminar el paquete 'dash'.

A veces es necesario eliminar un paquete para actualizar otro; este comando no puede actualizar paquetes en tales situaciones. Utilizar el actualización completa comando para actualizar tantos paquetes como sea posible.
actualización completa Actualiza los paquetes instalados a su versión más reciente, eliminando o instalando paquetes según sea necesario. Este comando es menos conservador que actualización segura y, por lo tanto, es más probable que realice acciones no deseadas. Sin embargo, es capaz de actualizar paquetes que actualización segura no se puede actualizar.

Si no aparece en la línea de comandos, aptitude intenta actualizar todos los paquetes que se pueden actualizar. De lo contrario, aptitude intenta actualizar solo los paquetes que se le indica que actualice. La puede extenderse con sufijos de la misma manera que los argumentos para instalación de aptitud , por lo que también puede dar instrucciones adicionales a aptitude aquí; por ejemplo, bash dash de actualización completa de aptitude- intenta actualizar el paquete 'bash' y eliminar el paquete 'dash'.

Este comando originalmente se llamaba dist-actualización por razones históricas, y aptitude todavía reconoce dist-actualización como sinónimo de actualización completa .
Mantener todo Cancela todas las acciones programadas en todos los paquetes; cualquier paquete cuyo estado fijo indica una instalación, eliminación o actualización tiene este estado fijo borrado.
olvidar-nuevo Olvida toda la información interna sobre qué paquetes son 'nuevos' (equivalente a presionar ' F 'cuando está en modo visual).
buscar Busca paquetes que coincidan con uno de los patrones proporcionados en la línea de comandos. Se mostrarán todos los paquetes que coincidan con cualquiera de los patrones dados; por ejemplo, búsqueda de aptitud '~ N' editar enumera todos los paquetes 'nuevos' y todos los paquetes cuyo nombre contiene 'editar'. Para obtener más información sobre patrones de búsqueda, consulte la sección 'Patrones de búsqueda' en el manual de referencia de aptitude.

En el ejemplo anterior, búsqueda de aptitud '~ N' editar tiene dos argumentos después de la búsqueda y, por lo tanto, busca dos patrones: '~ N' y 'editar'. Como se describe en la referencia del patrón de búsqueda, un solo patrón compuesto por dos subpatrones separados por un espacio (como ~ N editar ) coincide solo si ambos patrones coinciden. Por lo tanto, el comando búsqueda de aptitud '~ N editar' solo muestra paquetes 'nuevos' cuyo nombre contiene 'editar'.

Cada resultado de búsqueda se enumera en una línea separada. El primer carácter de cada línea indica el estado actual del paquete: los estados más comunes son pag , lo que significa que no existe ningún rastro del paquete en el sistema, c , lo que significa que el paquete se eliminó pero sus archivos de configuración permanecen en el sistema, I , lo que significa que el paquete está instalado, y v , lo que significa que el paquete es virtual. El segundo carácter indica la acción almacenada (si la hay; de lo contrario, se muestra un espacio en blanco) que se realizará en el paquete, siendo las acciones más comunes I , lo que significa que el paquete se instalará, D , lo que significa que el paquete se eliminará, y pag , lo que significa que se eliminarán el paquete y sus archivos de configuración. Si el tercer personaje es A , el paquete se instaló automáticamente.

Para personalizar el producción de búsqueda, consulte las opciones de la línea de comandos -F y --clasificar .
show Muestra información detallada sobre uno o más paquetes, enumerados después del comando de búsqueda. Si el nombre de un paquete contiene un carácter de tilde (' ~ ') o un signo de interrogación (' ? '), se tratará como un patrón de búsqueda y se mostrarán todos los paquetes coincidentes.

Si el nivel de verbosidad es 1 o mayor (es decir, al menos una -v está presente en la línea de comandos), se muestra información sobre todas las versiones del paquete. De lo contrario, la información sobre la 'versión candidata' (la versión que instalación de aptitud descargaría).

Puede mostrar información sobre una versión diferente del paquete agregando = al nombre del paquete; puede mostrar la versión de un archivo o versión en particular agregando / o / al nombre del paquete: por ejemplo, /inestable o / sid . Si alguno de estos está presente, solo se muestra la versión solicitada, independientemente del nivel de verbosidad.

Si el nivel de verbosidad es 1 o mayor, la arquitectura del paquete, el tamaño comprimido, Nombre del archivo , y se muestran los campos md5sum. Si el nivel de verbosidad es 2 o mayor, la versión o versiones seleccionadas se muestran una vez por cada archivo encontrado.
versiones Muestra las versiones de los paquetes enumerados en la línea de comandos.

aptitude [    ...] forget-new 
aptitude [    ...] safe-upgrade [    ...] 
Como puede ver, cada versión se enumera en una línea separada. Los tres caracteres más a la izquierda indican el estado actual, el estado planificado (si lo hay) y si el paquete se instaló automáticamente; para obtener más información sobre sus significados, consulte la documentación de búsqueda de aptitud . A la derecha del número de versión, puede encontrar las versiones desde las que está disponible la versión y la prioridad de pin de la versión.

Si el nombre de un paquete contiene un carácter de tilde (' ~ ') o un signo de interrogación (' ? '), se tratará como un patrón de búsqueda y se mostrarán todas las versiones coincidentes (consulte la sección' Patrones de búsqueda 'en el manual de referencia de aptitude). Esto significa que, por ejemplo, versiones de aptitude '~ i' muestra todas las versiones que están instaladas actualmente en el sistema y nada más, ni siquiera otras versiones de los mismos paquetes.

$ aptitude versiones '~ nexim4-daemon-light'

aptitude [    ...] purge    ... 
Si la entrada es un patrón de búsqueda, o si se van a mostrar más de las versiones de un paquete, aptitude agrupa automáticamente la salida por paquete, como se muestra arriba. Puede deshabilitar esto a través de --group-by = ninguno , en cuyo caso aptitude muestra una lista única de todas las versiones que se encontraron e incluye automáticamente el nombre del paquete en cada línea de salida:

aptitude extract-cache-subset       ... 
aptitude [    ...] search    ... 
Para deshabilitar el nombre del paquete, pase --show-package-names = nunca:

aptitude [...] add-user-tag ... 
aptitude [    ...] why [    ...]    
Además de las opciones anteriores, la información impresa para cada versión se puede controlar mediante la opción de línea de comandos -F . Las versiones del pedido que se muestran se pueden controlar mediante la opción de línea de comandos --clasificar . Para evitar que aptitude formatee la salida en columnas, use --deshabilitar-columnas .
agregar-etiqueta-de-usuario , eliminar-etiqueta-de-usuario Agrega una etiqueta de usuario o elimina una etiqueta de usuario del grupo de paquetes seleccionado. Si el nombre de un paquete contiene una tilde ('~') o un signo de interrogación ('?'), Se trata como un patrón de búsqueda y la etiqueta se agrega o elimina de todos los paquetes que coinciden con el patrón (consulte la sección 'Buscar Patrones 'en el manual de referencia de aptitude).

Las etiquetas de usuario son cadenas arbitrarias asociadas con un paquete. Se pueden utilizar con el ? etiqueta de usuario ( ) término de búsqueda, que selecciona todos los paquetes con una coincidencia de etiqueta de usuario.
por qué , Por qué no Explica la razón por la que un paquete en particular debe o no puede instalarse en el sistema.

Este comando busca paquetes que requieran o entren en conflicto con el paquete dado. Muestra una secuencia de dependencias que conducen al paquete de destino, junto con una nota que indica el estado de instalación de cada paquete en la cadena de dependencias:

aptitude [-S    ] [--autoclean-on-startup | --clean-on-startup | -i | -u] 
aptitude help 
El comando why encuentra una cadena de dependencia que instala el paquete nombrado en la línea de comando, como se indicó anteriormente. Tenga en cuenta que la dependencia que produjo aptitude en este caso es solo una sugerencia. Esto se debe a que ningún paquete actualmente instalado en esta computadora depende o recomienda el paquete kdepim; si hubiera una dependencia más fuerte disponible, aptitude la habría mostrado.

A diferencia de, Por qué no encuentra una cadena de dependencia que conduce a un conflicto con el paquete de destino:

$ aptitude versions wesnoth
p 1:1.4.5-1 100p 1:1.6.5-1 unstable 500p 1:1.7.14-1 experimental 1
Si uno o más están presentes, entonces aptitude comenzará su búsqueda en estos patrones; es decir, el primer paquete de la cadena que imprime será un paquete que coincida con el patrón en cuestión. Los patrones se consideran nombres de paquetes a menos que contengan un carácter de tilde ('~') o un signo de interrogación ('?'), En cuyo caso se tratan como patrones de búsqueda (consulte la sección 'Patrones de búsqueda' en la referencia de aptitude manual).

Si no hay patrones presentes, aptitude buscará cadenas de dependencia comenzando por los paquetes instalados manualmente. Esto muestra efectivamente los paquetes que han causado o causarían la instalación de un paquete determinado.

Aptitude por qué no realiza una resolución de dependencia completa; solo muestra relaciones directas entre paquetes. Por ejemplo, si A requiere B, C requiere D, y B y C entran en conflicto, aptitud por qué no D no producirá la respuesta 'A depende de B, B entra en conflicto con C y D depende de C'. De forma predeterminada, aptitude genera solo la cadena de dependencia 'más instalada, más fuerte, más ajustada y más corta'. Es decir, busca una cadena que solo contenga paquetes que están instalados o se instalarán; busca las dependencias más fuertes posibles bajo esa restricción; busca cadenas que eviten dependencias OR'ed y Provides; y busca la cadena de dependencia más corta que cumpla con esos criterios. Estas reglas se debilitan progresivamente hasta que se encuentra una coincidencia.

Si el nivel de verbosidad es 1 o más, entonces todas Las explicaciones que aptitude puede encontrar se muestran en orden inverso de relevancia. Si el nivel de verbosidad es 2 o más, se imprimirá una cantidad realmente excesiva de información de depuración en la salida estándar.

Este comando devuelve 0 si tiene éxito, 1 si no se pudo construir una explicación y -1 si ocurrió un error.
limpio Elimina todos los archivos .deb descargados previamente del paquete cache directorio (generalmente ubicado en / var / cache / apt / archivos ).
limpieza automática Elimina los paquetes almacenados en caché que ya no se pueden descargar. Esto le permite evitar que una caché crezca sin control con el tiempo sin vaciarla por completo.
registro de cambios Descarga y muestra el registro de cambios de Debian para cada uno de los fuente o binario paquetes.

De forma predeterminada, el registro de cambios de la versión que se instalaría con instalación de aptitud se descarga. Puede seleccionar una versión particular de un paquete agregando = al nombre del paquete; puede seleccionar la versión de un archivo o versión en particular agregando / o / al nombre del paquete (por ejemplo, /inestable o / sid ).
descargar Descarga el archivo .deb para el paquete dado en el directorio actual. Si el nombre de un paquete contiene un carácter de tilde ('~') o un signo de interrogación ('?'), Se tratará como un patrón de búsqueda y se descargarán todos los paquetes coincidentes.

Por defecto, la versión que se instalaría con instalación de aptitud se descarga. Puede seleccionar una versión particular de un paquete agregando = al nombre del paquete; puede seleccionar la versión de un archivo o versión en particular agregando / o al nombre del paquete (por ejemplo: /inestable o / sid ).
extraer-subconjunto-caché Copie el directorio de configuración de apt ( / etc / apt ) y un subconjunto de la base de datos del paquete en el directorio especificado. Si no hay paquetes en la lista, se copia toda la base de datos del paquete; de lo contrario, solo se copian las entradas correspondientes a los paquetes nombrados. Cada nombre de paquete puede ser un patrón de búsqueda y se seleccionarán todos los paquetes que coincidan con ese patrón. Se sobrescribirá cualquier archivo de base de datos de paquetes existente en el directorio de salida.

Las dependencias en las estrofas de paquetes binarios se reescribirán para eliminar las referencias a paquetes que no están en el conjunto seleccionado.
ayuda Muestra un resumen de los comandos y opciones disponibles.

Opciones

Las siguientes opciones pueden usarse para modificar el comportamiento de las acciones descritas anteriormente. Tenga en cuenta que, si bien se aceptarán todas las opciones para todos los comandos, algunas opciones no se aplican a comandos particulares y son ignoradas por esos comandos.

--add-user-tag Para actualización completa , actualización segura , prohibir la versión , mantener , Instalar en pc , Mantener todo , marcauto , unmarkauto , purga , reinstalar , retirar , despojar , y unmarkauto : agrega la etiqueta de usuario a todos los paquetes que se instalan, eliminan o actualizan con este comando como si fuera el agregar-etiqueta-de-usuario mando.
--add-user-tag-to ,
Para actualización completa , actualización segura , prohibir la versión , mantener , Instalar en pc , Mantener todo , marcauto , unmarkauto , purga , reinstalar , retirar , despojar , y unmarkauto : agrega la etiqueta de usuario a todos los paquetes que coinciden como si con el agregar-etiqueta-de-usuario mando. El patrón es un patrón de búsqueda como se describe en la sección 'Patrones de búsqueda' en el manual de referencia de aptitude.

Por ejemplo, aptitude safe-upgrade --add-user-tag-to 'new-installs,? action (install)' agrega la etiqueta nuevas instalaciones a todos los paquetes instalados por el actualización segura mando.
--permitir-nuevas-actualizaciones Cuando se utiliza el resolutor seguro (es decir, --safe-resolver fue aprobada, la acción es actualización segura , o Aptitude :: Siempre-Use-Safe-Resolver se establece en cierto ), permite que el solucionador de dependencias instale actualizaciones para paquetes independientemente del valor de Aptitude :: Safe-Resolver :: Sin nuevas actualizaciones .
--permitir-nuevas-instalaciones Permitir que el actualización segura comando para instalar nuevos paquetes; cuando se utiliza el resolutor seguro (es decir, --safe-resolver fue aprobada, la acción es actualización segura , o Aptitude :: Siempre-Use-Safe-Resolver se establece en cierto ), permite que el solucionador de dependencias instale nuevos paquetes. Esta opción tiene efecto independientemente del valor de Aptitude :: Safe-Resolver :: Sin instalaciones nuevas .
--permitido-no confiable Instale paquetes de fuentes que no sean de confianza sin preguntar. Solo debe usar esto si sabe lo que está haciendo, ya que podría comprometer fácilmente la seguridad de su sistema.
--deshabilitar-columnas Esta opción provoca búsqueda de aptitud y versiones de aptitud para generar sus resultados sin ningún formato especial. En particular: normalmente aptitude agrega espacio en blanco o truncar resultados de la búsqueda en un intento de encajar sus resultados en 'columnas' verticales. Con esta bandera, cada línea se formará reemplazando cualquier formato de escape en la cadena de formato con el texto correspondiente; los anchos de columna se ignoran.

Por ejemplo, las primeras líneas de salida de aptitude search -F '% p% V' --deshabilitar-columnas libedataserver puede ser:

Package exim4-daemon-light: i 4.71-3 100 p 4.71-4 unstable 500 Package exim4-daemon-light-dbg: p 4.71-4 unstable 500 
Como en el ejemplo anterior, --deshabilitar-columnas a menudo es útil en combinación con un formato de visualización personalizado establecido mediante la opción de línea de comandos -F .

Esto corresponde a la opción de configuración Aptitude :: CmdLine :: Disable-Columns .
-D , - show-deps Para los comandos que instalarán o eliminarán paquetes ( Instalar en pc , actualización completa , etc.), muestran breves explicaciones sobre instalaciones y eliminaciones automáticas.

Esto corresponde a la opción de configuración Aptitud :: CmdLine :: Show-Deps .
-D , - solo descarga Descargue los paquetes a la caché de paquetes según sea necesario, pero no instale ni elimine nada. De forma predeterminada, la caché de paquetes se almacena en / var / cache / apt / archivos .

Esto corresponde a la opción de configuración Aptitude :: CmdLine :: Solo descarga .
-F ,
--desplegar formato
Especifique el formato que se debe utilizar para mostrar la salida de los comandos de búsqueda y versiones. Por ejemplo, pasando ' % p% V% v ' por muestra el nombre de un paquete, seguido de su versión instalada actualmente y su versión disponible.

La opción de la línea de comandos --deshabilitar-columnas a menudo es útil en combinación con -F .

Para buscar , esto corresponde a la opción de configuración Aptitude :: CmdLine :: Package-Display-Format ; por versiones , esto corresponde a la opción de configuración Aptitude :: CmdLine :: Version-Display-Format .
-F Intente arreglar las dependencias de los paquetes rotos, incluso si eso significa ignorar las acciones solicitadas en la línea de comando.

Esto corresponde al elemento de configuración Aptitude :: CmdLine :: Fix-Broken .
--full-resolver Cuando se encuentren problemas de dependencia de paquetes, use el solucionador 'completo' predeterminado para resolverlos. A diferencia del resolutor 'seguro' activado por --safe-resolver , el solucionador completo eliminará con gusto los paquetes para cumplir con las dependencias. Puede resolver más situaciones que la caja fuerte. algoritmo , pero es más probable que sus soluciones sean indeseables.

Esta opción puede forzar el uso del resolutor completo incluso cuando Aptitude :: Siempre-Use-Safe-Resolver es verdad. La actualización segura El comando nunca usa el resolutor completo y no acepta el --full-resolver opción.
--agrupar por Controle cómo el comando de versiones agrupa su salida. Se reconocen los siguientes valores:

archivo para agrupar paquetes por el archivo en el que se encuentran ('estable', 'inestable', etc.). Si un paquete se encuentra en varios archivos, se muestra en cada uno de ellos.

auto para agrupar versiones por su paquete a menos que haya exactamente un argumento y no sea un patrón de búsqueda.

ninguno para mostrar todas las versiones en una sola lista sin ningún agrupamiento.

paquete para agrupar versiones por su paquete.

paquete-fuente para agrupar versiones por su paquete fuente.

versión-fuente para agrupar versiones por su paquete fuente y versión fuente.

Esto corresponde a la opción de configuración Aptitude :: CmdLine :: Versions-Group-By .
-h , --ayuda Muestra un breve mensaje de ayuda. Idéntico al ayuda acción.
--log-file = Si es un no vacío cuerda , los mensajes de registro se escribirán en él, excepto que si es '-', los mensajes se escribirán en la salida estándar en su lugar. Si esta opción aparece varias veces, la última aparición es la que entra en vigor.

Esto no afecta el registro de instalaciones que ha realizado aptitude ( / var / log / aptitude ); los mensajes de registro escritos con esta configuración incluyen eventos internos del programa, errores y mensajes de depuración. Ver la opción de línea de comandos --nivel de registro para tener más control sobre lo que se registra.

Esto corresponde a la opción de configuración Aptitude :: Logging :: File .
--log-level = ,
--log-level = :
--log-level = hace que aptitude registre solo mensajes cuyo nivel es o mas alto. Por ejemplo, configurar el nivel de registro en error provoca que solo se muestren mensajes en los niveles de registro error y fatal; todos los demás estarán ocultos. Los niveles de registro válidos (en orden descendente) son apagado , fatal , error , advertir , info , depurar , y rastro . El nivel de registro predeterminado es advertir .

--log-level = : provoca mensajes en para que solo se registre si su nivel es o mas alto.

--nivel de registro puede aparecer varias veces en la línea de comando; la configuración más específica es la que entra en vigor, por lo que si pasa --log-level=aptitude.resolver:fatal y --log-level = aptitude.resolver.hints.match: trace , luego mensajes en aptitude.resolver.hints.parse sólo se imprime si su nivel es fatal, pero todos los mensajes en aptitude.resolver.hints.match se imprimirá. Si establece el nivel de la misma categoría dos o más veces, la última configuración es la que surte efecto.

Esto no afecta el registro de instalaciones que ha realizado aptitude ( / var / log / aptitude ); los mensajes de registro escritos con esta configuración incluyen eventos internos del programa, errores y mensajes de depuración. Ver la opción de línea de comandos --archivo de registro para cambiar la ubicación de los mensajes de registro.

Esto corresponde al grupo de configuración Aptitud :: Registro :: Niveles .
--log-resolver Establezca algunos niveles de registro estándar relacionados con el resolutor, para producir una salida de registro adecuada para el procesamiento con herramientas automatizadas. Esto es equivalente a las opciones de la línea de comandos. --log-level = aptitude.resolver.search: trace --log-level = aptitude.resolver.search.tiers: información .
--no-nuevas-instalaciones Evitar actualización segura de instalar paquetes nuevos; cuando se utiliza el resolutor seguro (es decir, --safe-resolver fue pasado o Aptitude :: Siempre-Use-Safe-Resolver se establece en cierto ), prohíbe al solucionador de dependencias instalar nuevos paquetes. Esta opción tiene efecto independientemente del valor de Aptitude :: Safe-Resolver :: Sin instalaciones nuevas .

Esto imita el comportamiento histórico de actualización de apt-get .
--no-nuevas-actualizaciones Cuando se utiliza el resolutor seguro (es decir, --safe-resolver fue pasado o Aptitude :: Siempre-Use-Safe-Resolver se establece en cierto ), prohíbe al solucionador de dependencias instalar actualizaciones para paquetes independientemente del valor de Aptitude :: Safe-Resolver :: Sin nuevas actualizaciones .
--no-show-resolver-actions No muestre las acciones realizadas por el solucionador 'seguro', anulando cualquier opción de configuración o antes --show-resolver-actions .
-O , --clasificar Especifique el orden en el que deben mostrarse los resultados de los comandos de búsqueda y versiones. Por ejemplo, pasando ' installsize ' por enumera los paquetes en orden de acuerdo con su tamaño cuando se instalan.

El orden de clasificación predeterminado es nombre, versión .
-o = Establezca una opción de archivo de configuración directamente; por ejemplo, use -o Aptitud :: Log = / tmp / my-log para registrar las acciones de aptitude para / tmp / my-log .
-PAG , --inmediato Siempre muestre un mensaje antes de descargar, instalar o eliminar paquetes, incluso cuando no se realizarán acciones que no sean las solicitadas explícitamente.

Esto corresponde a la opción de configuración Aptitude :: CmdLine :: Always-Prompt.
--purga sin usar Si Aptitude :: Delete-Unused se establece en cierto (su valor predeterminado), además de eliminar cada paquete que ya no es necesario para ningún paquete instalado, aptitude también los purga, eliminando sus archivos de configuración y quizás otros datos importantes.

ESTA OPCIÓN PUEDE CAUSAR PÉRDIDA DE DATOS. NO LO USE A MENOS QUE SEPA LO QUE ESTÁ HACIENDO.

Esto corresponde a la opción de configuración Aptitud :: Purgar sin usar.
-q [ = ], --tranquilo [ = ] Suprime todos los indicadores de progreso incrementales, lo que hace que la salida se pueda registrar. Esto se puede suministrar varias veces para que el programa sea más silencioso, pero a diferencia de apt-get , aptitud no habilita -y Cuándo -q se suministra más de una vez.

El opcional = puede usarse para establecer directamente la cantidad de silencio (por ejemplo, para anular una configuración en /etc/apt/apt.conf ); hace que el programa se comporte como si -q había sido pasado exactamente veces.
-R , --sin-recomienda No trate las recomendaciones como dependencias al instalar nuevos paquetes (esto anula la configuración en /etc/apt/apt.conf y ~ / .aptitude / config ). Los paquetes instalados previamente debido a recomendaciones no se eliminarán.

Esto corresponde al par de opciones de configuración Apt :: Install-Recommends y Apt :: AutoRemove :: InstallRecommends .
-r , --con-recomienda Trate las recomendaciones como dependencias al instalar nuevos paquetes (esto anula la configuración en /etc/apt/apt.conf y ~ / .aptitude / config ).

Esto corresponde a la opción de configuración Apt :: Install-Recommends
--remove-user-tag Para actualización completa , versión prohibida de actualización segura , mantener , Instalar en pc , Mantener todo , marcauto , unmarkauto , purga , reinstalar , retirar , despojar , y unmarkauto : eliminar la etiqueta de usuario de todos los paquetes que se instalan, eliminan o actualizan con este comando como si fuera agregar-etiqueta-de-usuario mando.
--remove-user-tag-from , Para actualización completa , versión prohibida de actualización segura , mantener , Instalar en pc , Mantener todo , marcauto , unmarkauto , purga , reinstalar , retirar , despojar , y unmarkauto : eliminar la etiqueta de usuario de todos los paquetes que coinciden como si con el eliminar-etiqueta-de-usuario mando. El patrón es un patrón de búsqueda como se describe en la sección 'Patrones de búsqueda' en el manual de referencia de aptitude.

Por ejemplo, aptitude safe-upgrade --remove-user-tag-from 'no actualizado,? acción (actualización)' elimina la etiqueta no actualizada de todos los paquetes que el actualización segura El comando puede actualizarse.
-s , --simular En el modo de línea de comandos, imprima las acciones que normalmente se realizarían, pero en realidad no las realice. Esto no requiere privilegios de root. En la interfaz visual, siempre abra la caché en modo de solo lectura, independientemente de si es root.

Esto corresponde a la opción de configuración Aptitud :: Simular .
--safe-resolver Cuando se encuentren problemas de dependencia de paquetes, utilice un algoritmo 'seguro' para resolverlos. Este solucionador intenta conservar tantas opciones como sea posible; nunca elimina un paquete ni instala una versión de un paquete que no sea la versión candidata predeterminada del paquete. Es el mismo algoritmo utilizado en actualización segura ; Por supuesto, aptitude --safe-resolver actualización completa es equivalente a actualización segura de aptitude . Porque actualización segura utiliza siempre el resolutor seguro, no acepta la --safe-resolver bandera.

Esta opción es equivalente a establecer la variable de configuración Aptitude :: Siempre-Use-Safe-Resolver a cierto .
--solo programa Para los comandos que modifican los estados del paquete, programe las operaciones que se realizarán en el futuro, pero no las realice. Puede ejecutar acciones programadas ejecutando instalación de aptitud sin argumentos. Esto equivale a hacer las selecciones correspondientes en modo visual y luego salir del programa normalmente.

Por ejemplo, aptitude - evolución de instalación solo programada programará el evolución paquete para su posterior instalación.
--show-package-names Controla cuándo el comando de versiones muestra los nombres de los paquetes. Se permiten las siguientes configuraciones:

siempre: muestra los nombres de los paquetes cada vez que se ejecutan las versiones de aptitude.

auto: muestra los nombres de los paquetes cuando se ejecutan las versiones de aptitude si la salida no está agrupada por paquete, y hay un argumento de coincidencia de patrones o hay más de un argumento.

Nunca: nunca muestre los nombres de los paquetes en la salida de las versiones de aptitude.

Elemento de configuración: Aptitude :: CmdLine :: Versions-Show-Package-Names .
--show-resolver-actions Muestra las acciones realizadas por el solucionador 'seguro' y por actualización segura .

Al ejecutar el comando actualización segura o cuando la opcion --safe-resolver está presente, aptitude muestra un resumen de las acciones realizadas por el solucionador antes de imprimir la vista previa de la instalación. Esto es equivalente a la opción de configuración Aptitude::Safe-Resolver::Show-Resolver-Actions .
--show-summary [ = ] Cambia el comportamiento de aptitud por qué para resumir cada cadena de dependencia que genera, en lugar de mostrarla en forma larga. Si esta opción está presente y no es 'sin resumen', las cadenas que contienen dependencias Sugiere no se muestran: combine --show-summary con -v para ver un resumen de todas las razones por las que se instalará el paquete de destino.

puede ser cualquiera de los siguientes:

sin resumen: no mostrar un resumen (el comportamiento predeterminado si --show-summary no es presente).

primer paquete: mostrar el primer paquete de cada cadena. Este es el valor predeterminado de si no está presente.

primer paquete y tipo: mostrar el primer paquete de cada cadena, junto con la fuerza de la dependencia más débil de la cadena.

todos los paquetes: muestre brevemente cada cadena de dependencias que conducen al paquete de destino.

todos-paquetes-con-dep-versiones: muestre brevemente cada cadena de dependencias que conducen al paquete de destino, incluida la versión de destino de cada dependencia. Elemento de configuración: Aptitude :: CmdLine :: Show-Summary ; Si --show-summary está presente en la línea de comandos, anulará Aptitude :: CmdLine :: Show-Summary .

Ejemplo de uso de --show-summary , usado con -v para mostrar todas las razones por las que se instala un paquete:

|_+_| |_+_| |_+_| |_+_| --show-summary utilizado para listar una cadena en una línea:

|_+_| |_+_|
-t ,
- objetivo de liberación
Establezca la versión desde la que se deben instalar los paquetes. Por ejemplo, aptitud -t experimental ... instalará paquetes de la distribución experimental a menos que especifique lo contrario. Para las acciones de la línea de comandos ' registro de cambios ', ' descargar ', y ' show ', esto es equivalente a agregar / a cada paquete nombrado en la línea de comandos; para otros comandos, esto afecta a la versión candidata predeterminada de los paquetes de acuerdo con las reglas descritas en apt_preferences .

Esto corresponde al elemento de configuración APT :: Versión predeterminada .
-V , --show-versions Muestra qué versiones de paquetes se instalarán.

Esto corresponde a la opción de configuración Aptitude :: CmdLine :: Show-Versions .
-v , --verboso Causa algunos comandos (por ejemplo, show ) para mostrar información adicional. Esto se puede proporcionar varias veces para obtener más y más información.

Esto corresponde a la opción de configuración Aptitud :: CmdLine :: Verbose .
--versión Mostrar la versión de aptitud y algo de información sobre cómo fue compilado .
--visual-preview Al instalar o eliminar paquetes de la línea de comandos, en lugar de mostrar el indicador habitual, inicie la interfaz visual y muestre su pantalla de vista previa.
-EN , --mostrar-porqué En la vista previa que se muestra antes de instalar o eliminar los paquetes, muestre qué paquete instalado manualmente requiere cada paquete instalado automáticamente. Por ejemplo:

$ aptitude versions --group-by=none '~nexim4-daemon-light'
i exim4-daemon-light 4.71-3 100 p exim4-daemon-light 4.71-4 unstable 500 p exim4-daemon-light-dbg 4.71-4 unstable 500 
Cuando se combina con -v o un valor distinto de cero para Aptitud :: CmdLine :: Verbose , esto muestra la cadena completa de dependencias que llevan a cada paquete a ser instalado. Por ejemplo:

$ aptitude versions --show-package-names=never --group-by=none '~nexim4-daemon-light' 
i 4.71-3 100 p 4.71-4 unstable 500 p 4.71-4 unstable 500
Esta opción también describe por qué se eliminan los paquetes, como se muestra arriba. En este ejemplo, libdb4.2-dev conflictos con libdb-dev , que es proporcionado por libdb-dev .

Este argumento corresponde a la opción de configuración Aptitude :: CmdLine :: Show-Why y muestra la misma información que es calculada por aptitud por qué y aptitud por qué no .
-en , --ancho Especifique el ancho de visualización que se debe usar para la salida del comando de búsqueda (por defecto, se usa el ancho del terminal).

Esto corresponde a la opción de configuración Aptitude :: CmdLine :: Package-Display-Width
-y , - asumir-sí Cuando se presente un mensaje de sí / no, suponga que el usuario ingresó 'sí'. En particular, suprime el mensaje que aparece al instalar, actualizar o eliminar paquetes. Aún se muestran las solicitudes de acciones 'peligrosas', como la eliminación de paquetes esenciales. Esta opción anula -PAG .

Esto corresponde a la opción de configuración Aptitud :: CmdLine :: Suponer-Sí .
-CON Mostrar cuanto Espacio del disco será utilizado o liberado por los paquetes individuales que se instalen, actualicen o eliminen. Esto corresponde a la opción de configuración Aptitude :: CmdLine :: Show-Size-Changes.

Opciones de modo visual

--autoclean-on-startup Elimina los archivos descargados antiguos cuando se inicia el programa (equivalente a iniciar el programa y seleccionar inmediatamente Acciones → Limpiar archivos obsoletos ). No puede utilizar esta opción y ' --autoclean-on-startup ', ' -I ', o ' -u ' al mismo tiempo.
--limpiar al inicio Limpia la caché del paquete cuando se inicia el programa (equivalente a iniciar el programa y seleccionar inmediatamente Acciones → Limpiar caché de paquetes ). No puede utilizar esta opción y --autoclean-on-startup , -I , o -u al mismo tiempo.
-I Muestra una vista previa de la descarga cuando se inicia el programa (equivalente a iniciar el programa y presionar inmediatamente 'g'). No puede utilizar esta opción y --autoclean-on-startup , --limpiar al inicio , o -u al mismo tiempo.
-S Carga la información de estado ampliada de en lugar del archivo de estado estándar.
-u Comienza a actualizar las listas de paquetes tan pronto como se inicia el programa. No puede utilizar esta opción y --autoclean-on-startup , --limpiar al inicio , o -I al mismo tiempo.

Ambiente

La siguiente Variables de entorno afectar aptitud .

CASA Si $ HOME / .aptitude existe, aptitude almacenará su archivo de configuración en $ HOME / .aptitude / config . De lo contrario, busca el directorio de inicio del usuario actual usando getpwuid y coloque su archivo de configuración allí.
BUSCAPERSONAS Si se establece esta variable de entorno, aptitude la usa para mostrar registros de cambios cuando se invoca 'aptitude changelog'. Si no se establece, el valor predeterminado es más.
TMP Si TMPDIR no está configurado, aptitude almacenará su archivos temporales en TMP si esa variable está establecida. De lo contrario, los almacenará en / tmp .
TMPDIR aptitud almacenará sus archivos temporales en el directorio indicado por esta variable de entorno. Si TMPDIR no está configurado, entonces TMP se utilizará; Si TMP también está desarmado, entonces aptitude usa / tmp .

Archivos

/ Var / lib / aptitude / pkgstates El archivo donde se almacenan los estados de paquetes almacenados y algunas marcas de paquetes.
/etc/apt/apt.conf,
/etc/apt/apt.conf.d/*,
~ / .aptitude / config
Los archivos de configuración de aptitude. ~ / .aptitude / config anula /etc/apt/apt.conf . Ver apt.conf para la documentación del formato y contenido de estos archivos.

Ejemplos de

|_+_|

Carga aptitud en modo visual. Si su terminal lo admite (y probablemente lo haga), ingresará el programa en su terminal y se le presentará un sistema de menú que responde a los eventos del mouse.

|_+_|

Actualice las listas de paquetes APT. Esto es lo mismo que correr aptitud en modo visual y presionando 'u'.

|_+_|

Actualice tantos paquetes como sea posible sin eliminar ninguno.

|_+_|

Actualice los paquetes y elimine los paquetes si es necesario para resolver problemas de dependencia.

|_+_|

Busque en los repositorios de APT y muestre todos los paquetes que contienen el texto gnomo o dónde .

|_+_|

Muestra toda la información disponible sobre el paquete denominado perdición .

|_+_|

Instala el rubí paquete.

apto - Una interfaz APT unificada para la línea de comandos.
apt-cache - Obtenga información sobre los paquetes de software disponibles a través de APT.
apt-get - Herramienta de línea de comandos para administrar paquetes de software APT.
apt-file - Busque archivos individuales en todos los paquetes APT disponibles.
apto-marca - Cambiar o ver la configuración de paquetes APT individuales.
dpkg - Instalar, eliminar y mantener paquetes de software Debian.